Mikrotik - Доступ из локальной сети по IPCloud

Обсуждения, вопросы и решения по оборудованию Mikrotik
Аватара пользователя
alterak
Сообщения: 1
Зарегистрирован: 11 окт 2017, 08:11

Mikrotik - Доступ из локальной сети по IPCloud

Непрочитанное сообщение alterak »

В локальной сети установлен сервер к примеру с адресом 192.168.1.5. Он имеет доступ с внешней сети через IPCloud. Из интернета все работает нормально. Но как получить к нему доступ просто напросто из локальной сети по этой же ссылке IPCloud?
Например с домашнего ПК (находится в одной сети и имеет адрес 192.168.1.242) если я введу в браузере ссылку IPCloud, то страница не открывается, а если введу напрямую IP адрес 192.168.1.5 то конечно же открывается нормально.
В локальной сети пинги по ссылке IPCloud проходят норм, значит доступ ДО микротика есть, но дальше до сервера маршрут из локальной сети пробиться не может-(
Уже советовали Hairpin NAT, но тут возникает другая проблема - ведь адрес на внешнем интерфейсе динамический и постоянно меняется и для этого активирован был IPCloud.
Аватара пользователя
ustim
Администратор
Сообщения: 159
Зарегистрирован: 17 янв 2017, 13:11
Откуда: Сочи
Контактная информация:

Re: Mikrotik - Доступ из локальной сети по IPCloud

Непрочитанное сообщение ustim »

Есть уже готовое решение:

ПРАВИЛО-1

Код: Выделить всё

/ip firewall nat
add chain=dstnat src-address=192.168.1.0/24(sub-net) \
dst-address=WAN-IP protocol=tcp dst-port=80 \
action=dst-nat to-address=192.168.1.5(local-ip(web-srv)) to ports=80
ПРАВИЛО-2

Код: Выделить всё

/ip firewall nat
add chain=srcnat src-address=192.168.1.0/24(sub-net) \
dst-address=192.168.1.5(local-ip(web-srv)) protocol=tcp dst-port=80 \
action=masquerade
Ответить